Inter-domain traffic steering solution with EPE and XTC ODN

Introduction

 

Now more customer complains their Peering network not flexible and hard to control, that will cause peering link’s utilization not balance and waste of resources. As follow the example on Router-2, customer peering device connect to multi ISP, each ISP sends full internet route, select only based on the BGP. BGP select rule only based on the route but not real traffics, that may be cause port-A’s traffics have 8G, but port-B and port-C only have 4G, if want to adjust BGP select, only change RPL that more complex, and due to route from internet and multi ISP, so route maybe change at some time, in order to balance peering link, customer must continue to adjust their RPL.

Could we have more flexible and simplest way to resolve the issue? The answer is Yes 🙂 we can achieve the task by Segment Routing – Egress Peer Engineering. Now some customer had deployed the solution, that combine NetFlow, Openbmp to check AS/traffics of prefix, then send BGP LU(EPE label) to ingress node, and easy to control traffics.

Please attention, if the customer has less prefix and not same as Telecom, we can not include Netflow and Openbmp, only control by BGP controller that is ok.

For this articles, show a demo for EPE, due to EPE only resolve the peering egress issue, so I combine our SRTE + ODN, that archive path control in IGP, the solution is much flexible! ODN is our great SRTE solution, that can scales/easy deployment SRTE, only control by color is ok. You will understand this key point after checking the article 🙂  If you have any questions, please let me know.

Topology

 

BGP Controller deploys by our XTC.
PCE Controller deploys by our XTC.
BGP LU between XTC and ingress route Node-3.
EPE only config on Node-5, Gi0/0/0/1: 24005; Gi0/0/0/3: 24004
IGP is ISIS and enables SR; no VRF, only Global BGP route

Demo Summary

  1. If no EPE and SRTE, traffic follow the Black Line from 192.168.0.1 of Node-1 to 1.1.1.1 of Node-8.
  2. After activating SRTE by TE metric, traffic will follow the Yellow Line from 192.168.0.1 of Node-1 to 1.1.1.1 of Node-8.
  3. After activating send EPE label by BGP LU on XTC Controller, traffics will follow the Orange Line from 192.168.0.1 of Node-1 to 1.1.1.1 of Node-8.

Please attention, If our XTC Controller down, will not affect the traffics path, only affect peering egress selection.

Detail Demo Step

01. Enable ISIS and SR and Segment Routing on Node2,3,3,4

interface Loopback0
 description Loopback  
 ipv4 address 192.168.0.x 255.255.255.255
!
router isis 1
 net 49.1921.6800.000x.00
 distribute link-state  <<< must have! that build srte topology
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
  mpls traffic-eng router-id Loopback0
  segment-routing mpls
 !
 interface Loopback0
  passive
  circuit-type level-2-only
  address-family ipv4 unicast
   prefix-sid absolute 1600x <<< node sid
  !
 !        
 interface GigabitEthernetx/x/x/x
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
   metric 1
  !
 !
!
router bgp 65535
 bgp router-id 192.168.0.x
 bgp bestpath as-path multipath-relax  <<< only config on Node-5
 address-family ipv4 unicast
  network 192.168.0.x/32
 !
 neighbor <CE>
  remote-as <AS>
  description eBGP peer iosxrv-x  
  address-family ipv4 unicast
   route-policy bgp_in in
   route-policy bgp_out out
 !
 neighbor 192.168.0.x
  remote-as 65535
  description iBGP peer iosxrv-x  
  update-source Loopback0
  address-family ipv4 unicast
   route-policy bgp_in in
   route-policy bgp_out out
   next-hop-self
  !
 !
!
segment-routing
 traffic-eng

02. Check BGP route for 1.1.1.1/32 and 2.2.2.2/32 on Node-5

RP/0/0/CPU0:iosxrv-5#sh bgp
Sun Sep 16 03:17:52.654 UTC
BGP router identifier 192.168.0.5, local AS number 65535
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 45
BGP main routing table version 45
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32         10.0.0.26                0             0 200 i
*                     10.0.0.34                0             0 300 i
*> 2.2.2.2/32         10.0.0.26                0             0 200 i
*                     10.0.0.34                0             0 300 i
*>i192.168.0.1/32     192.168.0.3              0    100      0 100 i
*>i192.168.0.3/32     192.168.0.3              0    100      0 i
*> 192.168.0.5/32     0.0.0.0                  0         32768 i
*> 192.168.0.6/32     10.0.0.26                0             0 200 i
*> 192.168.0.8/32     10.0.0.34                0             0 300 i
          
Processed 7 prefixes, 9 paths
RP/0/0/CPU0:iosxrv-5#
RP/0/0/CPU0:iosxrv-5#sh route 1.1.1.1/32
Sun Sep 16 03:18:02.263 UTC

Routing entry for 1.1.1.1/32
  Known via "bgp 65535", distance 20, metric 0
  Tag 200, type external
  Installed Sep 14 10:02:25.019 for 1d17h
  Routing Descriptor Blocks
    10.0.0.26, from 10.0.0.26, BGP external, BGP multi path
      Route metric is 0
    10.0.0.34, from 10.0.0.34, BGP external, BGP multi path
      Route metric is 0
  No advertising protos. 
RP/0/0/CPU0:iosxrv-5#
RP/0/0/CPU0:iosxrv-5#sh bgp 1.1.1.1/32
Sun Sep 16 03:18:12.032 UTC
BGP routing table entry for 1.1.1.1/32
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 33          33
Last Modified: Sep 14 10:02:25.451 for 1d17h
Paths: (2 available, best #1)
  Advertised IPv4 Unicast paths to update-groups (with more than one peer):
    0.3 
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    192.168.0.3     
  Path #1: Received by speaker 0
  Advertised IPv4 Unicast paths to update-groups (with more than one peer):
    0.3 
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    192.168.0.3     
  200
    10.0.0.26 from 10.0.0.26 (192.168.0.6)
      Origin IGP, metric 0, localpref 100, valid, external, best, group-best, multipath
      Received Path ID 0, Local Path ID 1, version 33
      Origin-AS validity: (disabled)
  Path #2: Received by speaker 0
  Not advertised to any peer
  300
    10.0.0.34 from 10.0.0.34 (192.168.0.8)
      Origin IGP, metric 0, localpref 100, valid, external, multipath
      Received Path ID 0, Local Path ID 0, version 0
      Origin-AS validity: (disabled)

03. Check BGP route for 1.1.1.1/32 and 2.2.2.2/32 on Node-5

RP/0/0/CPU0:iosxrv-3#sh bgp
Sun Sep 16 03:22:43.793 UTC
BGP router identifier 192.168.0.3, local AS number 65535
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 87
BGP main routing table version 87
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
*>i1.1.1.1/32         192.168.0.5              0    100      0 200 i
*>i2.2.2.2/32         192.168.0.5              0    100      0 200 i
*> 192.168.0.1/32     10.0.0.5                 0             0 100 i
*> 192.168.0.3/32     0.0.0.0                  0         32768 i
*>i192.168.0.5/32     192.168.0.5              0    100      0 i
*>i192.168.0.6/32     192.168.0.5              0    100      0 200 i
*>i192.168.0.8/32     192.168.0.5              0    100      0 300 i

Processed 7 prefixes, 7 paths
RP/0/0/CPU0:iosxrv-3#sh route 1.1.1.1/32
Sun Sep 16 03:22:56.262 UTC

Routing entry for 1.1.1.1/32
  Known via "bgp 65535", distance 200, metric 0
  Tag 200, type internal
  Installed Sep 16 03:14:42.226 for 00:08:14
  Routing Descriptor Blocks
    192.168.0.5, from 192.168.0.5
      Route metric is 0
  No advertising protos. 
RP/0/0/CPU0:iosxrv-3#sh bgp 1.1.1.1/32
Sun Sep 16 03:22:59.872 UTC
BGP routing table entry for 1.1.1.1/32
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 84          84
Last Modified: Sep 16 03:14:42.328 for 00:08:17
Paths: (1 available, best #1)
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  Path #1: Received by speaker 0
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  200
    192.168.0.5 (metric 2) from 192.168.0.5 (192.168.0.5)
      Origin IGP, metric 0, localpref 100, valid, internal, best, group-best
      Received Path ID 0, Local Path ID 1, version 84

04. Check default flow path from 192.168.0.1 of Node-1 to 1.1.1.1/2.2.2.2, all traffic route to Node-8

RP/0/0/CPU0:iosxrv-1#traceroute 1.1.1.1 source lo0
Sun Sep 16 03:25:25.588 UTC

Type escape sequence to abort.
Tracing the route to 1.1.1.1

 1  10.0.0.6 0 msec  0 msec  0 msec 
 2  10.0.0.18 [MPLS: Label 16005 Exp 0] 9 msec  9 msec  9 msec 
 3  10.0.0.22 9 msec  9 msec  9 msec 
 4  10.0.0.34 9 msec  *  9 msec 
RP/0/0/CPU0:iosxrv-1#
RP/0/0/CPU0:iosxrv-1#
RP/0/0/CPU0:iosxrv-1#traceroute 2.2.2.2 source lo0
Sun Sep 16 03:25:36.267 UTC

Type escape sequence to abort.
Tracing the route to 2.2.2.2

 1  10.0.0.6 9 msec  0 msec  0 msec 
 2  10.0.0.18 [MPLS: Label 16005 Exp 0] 9 msec  9 msec  9 msec 
 3  10.0.0.22 9 msec  9 msec  9 msec 
 4  10.0.0.34 9 msec  *  19 msec

05. Enable ODN + XTC on Node-3 and XTC

RP/0/0/CPU0:iosxrv-3#sh run segment-routing 
Sun Sep 16 03:29:51.063 UTC
segment-routing
 traffic-eng
  interface GigabitEthernet0/0/0/2
   metric 1000
  !
  on-demand color 99 <<< set only one odn, if route with color, will auto trigger policy
   dynamic
    pcep  <<< compute path by PCE
    !
    metric
     type te  <<< use te metric, in future, we can use real delay
    !
   !
  !
  pcc  <<< config PCC
   source-address ipv4 192.168.0.3
   pce address ipv4 192.168.0.12  <<< this is XTC
    password encrypted 030752180500
   !
   report-all  <<< this command will report all srte lsp to pce
  !
 !
!

RP/0/0/CPU0:iosxrv-3#sh segment-routing traffic-eng pcc ipv4 peer detail 
Sun Sep 16 03:33:42.648 UTC

PCC's peer database:
--------------------

Peer address: 192.168.0.12 (best PCE) <<< now I only deploy one XTC
 State up
 Capabilities: Stateful, Update, Segment-Routing, Instantiation
 PCEP has been up for: 1d21h
 Local keepalive timer is 30 seconds
 Remote keepalive timer is 30 seconds
 Local dead timer is 120 seconds
 Remote dead timer is 120 seconds
 Statistics:
 Open messages: rx 1 | tx 1 
 Close messages: rx 0 | tx 0 
 Keepalive messages: rx 5492 | tx 5486 
 Error messages: rx 0 | tx 0 
 Report messages: rx 0 | tx 47 
 Update messages: rx 3 | tx 0 

RP/0/0/CPU0:XTC#sh run pce
Sun Sep 16 03:35:07.457 UTC
pce
 address ipv4 192.168.0.12
 rest
 user cisco
 !
 authentication basic
 !
 logging
 no-path
 fallback
 !
 password encrypted 01100F175804
!

06. Set 1.1.1.1 with color 99 on Node-5

RP/0/0/CPU0:iosxrv-5#show configuration commit changes last 1
Sun Sep 16 03:39:02.797 UTC
Building configuration...
!! IOS XR Configuration 7.0.1.19I
router bgp 65535
 neighbor 192.168.0.3
  address-family ipv4 unicast
   route-policy bgp_color out  <<< set color before send to Node-3 or RR
  !
 !
!
end

RP/0/0/CPU0:iosxrv-5#sh run route-policy bgp_color   
Sun Sep 16 03:39:25.505 UTC
route-policy bgp_color
  if destination in (1.1.1.1/32) then
    set extcommunity color RED
  endif
  pass
end-policy
!

RP/0/0/CPU0:iosxrv-5#sh run extcommunity-set opaque RED <<< ext community
Sun Sep 16 03:39:48.474 UTC
extcommunity-set opaque RED
  99
end-set
!

07. Node-3 will auto-create a SR Policy and auto steering traffics to SRTE

RP/0/0/CPU0:iosxrv-3#sh bgp 1.1.1.1/32
Sun Sep 16 03:44:01.445 UTC
BGP routing table entry for 1.1.1.1/32
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 89          89
Last Modified: Sep 16 03:38:45.328 for 00:05:16
Paths: (1 available, best #1)
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  Path #1: Received by speaker 0
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  200
    192.168.0.5 C:99 (bsid:24007) (metric 2) from 192.168.0.5 (192.168.0.5) 
      Origin IGP, metric 0, localpref 100, valid, internal, best, group-best
      Received Path ID 0, Local Path ID 1, version 88
      Extended community: Color:99 
      SR ODN policy color 99, up, registered, bsid 24007, if-handle 0x00000190 <<< with color 99

RP/0/0/CPU0:iosxrv-3#
RP/0/0/CPU0:iosxrv-3#sh segment-routing traffic-eng policy detail        
Sun Sep 16 03:44:08.045 UTC

SR-TE policy database
---------------------

Name: bgp_AP_10 (Color: 99, End-point: 192.168.0.5)
    Status:
      Admin: up  Operational: up for 00:05:26 (since Sep 16 03:38:41.917)
    Candidate-paths:
      Preference 100:
        Dynamic (pce 192.168.0.12) (active) <<< XTC(PCE) had replay the result
          Metric Type: TE,   Path Accumulated Metric: 3 
            16007 [Prefix-SID, 192.168.0.7] <<< only add Node-7's Node-SID
            16005 [Prefix-SID, 192.168.0.5]
    Attributes:
      Binding SID: 24007
        Allocation mode: dynamic
        State: Programmed
        Policy selected: yes
      Forward Class: 0
      Steering BGP disabled: no
      IPv6 caps enable: yes
      Distinguisher: 0
    Auto-policy info:
      Creator: BGP

RP/0/0/CPU0:iosxrv-3#
RP/0/0/CPU0:iosxrv-3#sh mpls forwarding                                  
Sun Sep 16 03:44:14.854 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
16002  Pop         SR Pfx (idx 2)     Gi0/0/0/1    10.0.0.9        0           
16004  Pop         SR Pfx (idx 4)     Gi0/0/0/2    10.0.0.18       0           
16005  16005       SR Pfx (idx 5)     Gi0/0/0/2    10.0.0.18       2653        
16007  16007       SR Pfx (idx 7)     Gi0/0/0/1    10.0.0.9        0           
24000  Pop         SR Adj (idx 1)     Gi0/0/0/4    10.0.2.6        0           
24001  Pop         SR Adj (idx 3)     Gi0/0/0/4    10.0.2.6        0           
24002  Pop         SR Adj (idx 1)     Gi0/0/0/1    10.0.0.9        0           
24003  Pop         SR Adj (idx 3)     Gi0/0/0/1    10.0.0.9        0           
24004  Pop         SR Adj (idx 1)     Gi0/0/0/2    10.0.0.18       0           
24005  Pop         SR Adj (idx 3)     Gi0/0/0/2    10.0.0.18       0           
24007  Pop         No ID              bgp_AP_10    point2point     0   

08. Check the flow path from 192.168.0.1 of Node-1 to 1.1.1.1/2.2.2.2, IGP path had changed for 1.1.1.1.

RP/0/0/CPU0:iosxrv-1#traceroute 1.1.1.1 source lo0
Sun Sep 16 03:46:18.282 UTC

Type escape sequence to abort.
Tracing the route to 1.1.1.1

 1  10.0.0.6 9 msec  0 msec  0 msec 
 2  10.0.0.9 [MPLS: Labels 16007/16005 Exp 0] 19 msec  19 msec  19 msec 
 3  10.0.0.14 [MPLS: Label 16005 Exp 0] 9 msec  9 msec  9 msec
 4  10.0.0.29 9 msec  9 msec  9 msec 
 5  10.0.0.34 19 msec  *  19 msec 
RP/0/0/CPU0:iosxrv-1#
RP/0/0/CPU0:iosxrv-1#traceroute 2.2.2.2 source lo0
Sun Sep 16 03:46:26.101 UTC

Type escape sequence to abort.
Tracing the route to 2.2.2.2

 1  10.0.0.6 0 msec  0 msec  0 msec 
 2  10.0.0.18 [MPLS: Label 16005 Exp 0] 19 msec  9 msec  9 msec 
 3  10.0.0.22 9 msec  9 msec  9 msec 
 4  10.0.0.34 9 msec  *  9 msec 
RP/0/0/CPU0:iosxrv-1#

RP/0/0/CPU0:iosxrv-3#sh segment-routing traffic-eng forwarding policy 
Sun Sep 16 04:05:31.377 UTC
Policy Segment Outgoing Outgoing Next Hop Bytes 
Name List Label Interface Switched 
------------- --------------- ----------- ------------------- --------------- ------------
bgp_AP_10 Autolist_10_1* 16007 Gi0/0/0/1 10.0.0.9 384

09. Enable EPE on Node-5, only by one command

RP/0/0/CPU0:iosxrv-5#sh run router bgp 65535 nei 10.0.0.26
Sun Sep 16 03:49:16.805 UTC
router bgp 65535
 neighbor 10.0.0.26
  remote-as 200
  egress-engineering    <<< epe cmd
  description iBGP peer iosxrv-6  
  address-family ipv4 unicast
   route-policy bgp_in in
   route-policy bgp_out out
  !
 !
!

RP/0/0/CPU0:iosxrv-5#
RP/0/0/CPU0:iosxrv-5#sh run router bgp 65535 nei 10.0.0.34
Sun Sep 16 03:49:19.964 UTC
router bgp 65535
 neighbor 10.0.0.34
  remote-as 300
  egress-engineering   <<< epe cmd
  description iBGP peer iosxrv-8  
  address-family ipv4 unicast
   route-policy bgp_in in
   route-policy bgp_out out
  !
 !
!

RP/0/0/CPU0:iosxrv-5#
RP/0/0/CPU0:iosxrv-5#sh bgp egress-engineering 
Sun Sep 16 03:49:27.744 UTC

 Egress Engineering Peer Set: 10.0.0.26/32 (14637008)
        Nexthop: 10.0.0.26
        Version: 11, rn_version: 11
          Flags: 0x00000006
      Local ASN: 65535
     Remote ASN: 200
      Local RID: 192.168.0.5
     Remote RID: 192.168.0.6
  Local Address: 10.0.0.25
      First Hop: 10.0.0.26
           NHID: 1
            IFH: 0x40
          Label: 24005, Refcount: 3 <<< EPE Label
        rpc_set: 153f29b4, ID: 6

 Egress Engineering Peer Set: 10.0.0.34/32 (14636f64)
        Nexthop: 10.0.0.34
        Version: 10, rn_version: 10
          Flags: 0x00000006
      Local ASN: 65535
     Remote ASN: 300
      Local RID: 192.168.0.5
     Remote RID: 192.168.0.8
  Local Address: 10.0.0.33
      First Hop: 10.0.0.34
           NHID: 2
            IFH: 0x80
          Label: 24004, Refcount: 3 <<< EPE Label
        rpc_set: 155f70a4, ID: 5

10. Before Encap EPE labels on Node-3

RP/0/0/CPU0:iosxrv-3#sh cef 1.1.1.1/32 detail 
Sun Sep 16 03:53:42.295 UTC
1.1.1.1/32, version 144, internal 0x5000001 0x0 (ptr 0xa14eefa8) [1], 0x0 (0x0), 0x0 (0x0)
 Updated Sep 16 03:38:44.986
 Prefix Len 32, traffic index 0, precedence n/a, priority 4
  gateway array (0xa14282cc) reference count 1, flags 0x2010, source rib (7), 0 backups
                [1 type 3 flags 0x48441 (0xa1478958) ext 0x0 (0x0)]
  LW-LDI[type=0, refc=0, ptr=0x0, sh-ldi=0x0]
  gateway array update type-time 1 Sep 16 03:38:44.986
 LDI Update time Sep 16 03:38:44.986

  Level 1 - Load distribution: 0
  [0] via 192.168.0.5/32, recursive

   via local-label 24007, 3 dependencies, recursive [flags 0x6000]
    path-idx 0 NHID 0x0 [0xa17cc058 0x0]
    recursion-via-label
    next hop via 24007/1/21 <<< you can check no any EPE label

    Load distribution: 0 (refcount 1)

    Hash  OK  Interface                 Address
    0     Y   bgp_AP_10                 point2point <<< recurse to ODN policy

11. Send BGP with color/EPE Label by XTC

RP/0/0/CPU0:XTC#sh run router bgp 65535 
Sun Sep 16 03:55:35.393 UTC
router bgp 65535
 bgp router-id 192.168.0.12
 address-family ipv4 unicast
  network 1.1.1.1/32
  allocate-label all <<< support deliver labels
 !
 neighbor 10.0.2.5
  remote-as 65535
  address-family ipv4 labeled-unicast <<< enable BGP LU
   route-policy frank out
  !
 !
!

RP/0/0/CPU0:XTC#sh run route-policy frank
Sun Sep 16 03:55:56.632 UTC
route-policy frank
  if destination in (1.1.1.1) then
    set next-hop 192.168.0.5
    set label 24005 <<< send EPE labels
    set local-preference 1000  <<< let router select the path
    set extcommunity color red <<< that same Node-5, so not show detail
  endif
end-policy
!

12. Check CEF again on Node-3

RP/0/0/CPU0:iosxrv-3#sh bgp 1.1.1.1/32
Sun Sep 16 04:02:09.861 UTC
BGP routing table entry for 1.1.1.1/32
Versions:
  Process           bRIB/RIB  SendTblVer
  Speaker                 90          90
Last Modified: Sep 16 04:01:21.328 for 00:00:48
Paths: (2 available, best #1)
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  Path #1: Received by speaker 0  <<< this path from XTC
  Advertised IPv4 Unicast paths to peers (in unique update groups):
    10.0.0.5        
  Local
    192.168.0.5 C:99 (bsid:24007) (metric 2) from 10.0.2.6 (192.168.0.12)
      Received Label 24005 
      Origin IGP, metric 0, localpref 1000, valid, internal, best, group-best, labeled-unicast
      Received Path ID 0, Local Path ID 1, version 90
      Extended community: Color:99 
      SR ODN policy color 99, up, registered, bsid 24007, if-handle 0x00000190

  Path #2: Received by speaker 0  <<< this path from Node-5
  Not advertised to any peer
  200
    192.168.0.5 C:99 (bsid:24007) (metric 2) from 192.168.0.5 (192.168.0.5)
      Origin IGP, metric 0, localpref 100, valid, internal, group-best
      Received Path ID 0, Local Path ID 0, version 0
      Extended community: Color:99 
      SR ODN policy color 99, up, registered, bsid 24007, if-handle 0x00000190

RP/0/0/CPU0:iosxrv-3#
RP/0/0/CPU0:iosxrv-3#sh cef 1.1.1.1/32
Sun Sep 16 04:03:07.147 UTC
1.1.1.1/32, version 146, internal 0x5000001 0x0 (ptr 0xa14eefa8) [1], 0x0 (0xa14d0cd8), 0xa08 (0xa1757318)
 Updated Sep 16 04:01:20.885
 Prefix Len 32, traffic index 0, precedence n/a, priority 4
   via local-label 24007, 3 dependencies, recursive [flags 0x6000]
    path-idx 0 NHID 0x0 [0xa17cbfcc 0x0]
    recursion-via-label
    next hop via 24007/0/21
     next hop bgp_AP_10    labels imposed {ImplNull 24005}

13. Check the flow path from 192.168.0.1 of Node-1 to 1.1.1.1/2.2.2.2, egress port had changed on Node-5

RP/0/0/CPU0:iosxrv-1#traceroute 1.1.1.1 source lo0
Sun Sep 16 04:06:47.158 UTC

Type escape sequence to abort.
Tracing the route to 1.1.1.1

 1  10.0.0.6 9 msec  0 msec  0 msec 
 2  10.0.0.9 [MPLS: Labels 16007/16005/24005 Exp 0] 49 msec  19 msec  19 msec 
 3  10.0.0.14 [MPLS: Labels 16005/24005 Exp 0] 19 msec  19 msec  19 msec 
 4  10.0.0.29 [MPLS: Label 24005 Exp 0] 19 msec  19 msec  19 msec 
 5  10.0.0.26 9 msec  *  19 msec
RP/0/0/CPU0:iosxrv-1#
RP/0/0/CPU0:iosxrv-1#traceroute 2.2.2.2 source lo0
Sun Sep 16 04:06:54.747 UTC

Type escape sequence to abort.
Tracing the route to 2.2.2.2

 1  10.0.0.6 0 msec  0 msec  0 msec 
 2  10.0.0.18 [MPLS: Label 16005 Exp 0] 9 msec  9 msec  9 msec 
 3  10.0.0.22 9 msec  9 msec  9 msec 
 4  10.0.0.34 9 msec  *  9 msec
0
你可以留言,或者trackback 从你的网站

2 Responses to “Inter-domain traffic steering solution with EPE and XTC ODN”

  1. monking说道:

    images are dead, please check it. Thx

  2. frank说道:

    Thanks, had updated~ 🙂

留言哦