Static BFD Configuration Summary

0

由于最近处理一个静态BFD的问题。
在此贴出BFD的配置及相关的资源链接供大家参考。
关于相关BFD协议的内容和他的模式问题,本想用dynamips加12.2(33)SRC来做测试并抓包分析,但发现一配置BFD,模拟器就crash,先后更换了SRD,SRE及更换了NPE-G1和 NPE-G2,现象一样存在。毕竟只是模拟器呀。。。。。。

所以关于相关BFD的更进一步分析,只能等到手头有设备时直接SPAN了。

注:VRF下的静态BFD,只从12.2(33)SRC才开始支持,支持平台为7600和7200。
6500需要在12.2(33)SXI才支持。下面是在正常端口下BFD的配置:

7607-1:
———————-

interface GigabitEthernet3/1
 ip address 1.1.1.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
ip route static bfd GigabitEthernet3/1 1.1.1.2
ip route 10.1.1.1 255.255.255.255 GigabitEthernet3/1 1.1.1.2

7607-2:
———————-

interface FastEthernet3/1
 ip address 1.1.1.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
ip route static bfd FastEthernet3/1 1.1.1.1
ip route 22.1.1.1 255.255.255.255 FastEthernet3/1 1.1.1.1

下面是在VRF端口下BFD的配置:

7609-1:
———————-

interface GigabitEthernet3/1
no ip address
!
interface GigabitEthernet3/1.1
 encapsulation dot1Q 100
 ip vrf forwarding test
 ip address 2.1.1.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface GigabitEthernet3/1.2
 encapsulation dot1Q 101
 ip vrf forwarding test2
 ip address 1.1.1.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3

C7609-1#sh run | i ip route
ip route static bfd GigabitEthernet3/1.1 2.1.1.2
ip route static bfd GigabitEthernet3/1.2 1.1.1.2
ip route vrf test 11.1.1.1 255.255.255.255 GigabitEthernet3/1.1 2.1.1.2
ip route vrf test2 10.1.1.1 255.255.255.255 GigabitEthernet3/1.2 1.1.1.2

7609-2:
———————-

interface FastEthernet3/1
 no ip address
!
interface FastEthernet3/1.1
 encapsulation dot1Q 100
 ip vrf forwarding test
 ip address 2.1.1.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet3/1.2
 encapsulation dot1Q 101
 ip vrf forwarding test2
 ip address 1.1.1.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3

7609-2#sh run | i ip route
ip route static bfd FastEthernet3/1.1 2.1.1.1
ip route static bfd FastEthernet3/1.2 1.1.1.1
ip route vrf test 21.1.1.1 255.255.255.255 FastEthernet3/1.1 2.1.1.1
ip route vrf test2 20.1.1.1 255.255.255.255 FastEthernet3/1.2 1.1.1.1

注意在SVI下是不支持BFD的,以前是可以配置的,但是不生效。
所以在新的IOS下就直接关闭了相关配置命令。有兴趣的可以查看这个bug:CSCsj08713

下面是关于BFD的CCO文档(注意有时文档中写的命令也是有问题的,例如“ip route static bfd [vrf vrf-name] ”就是不存在的):
http://www.cisco.com/en/US/docs/ios/iproute_bfd/configuration/guide/irb_bfd.html

本文出自 Frank's Blog

版权声明:


本文链接:Static BFD Configuration Summary
版权声明:本文为原创文章,仅代表个人观点,版权归 Frank Zhao 所有,转载时请注明本文出处及文章链接
你可以留言,或者trackback 从你的网站

No Responses to “Static BFD Configuration Summary”

  1. leo说道:

    请教一下,对于vrf的情况配置好以后可以在全局下#show bfd neighbor看到neighbor吗?还是说要跟vrf test看?

    0
  2. frank说道:

    不同平台不同版本有些区别,GSR上直接show bfd nei就可以,你可以都试试

    0
  3. leo说道:

    谢谢,我的是7609,没法登设备。

    0
  4. leo说道:

    你有试过这种情况吗?

    ip route static bfd GigabitEthernet1/1.15 10.1.1.1

    ip route vrf test 10.2.2.0 255.255.255.0 GigabitEthernet1/1.15 10.1.1.2

    对端设备有2个口,10.1.1.2专门跑bfd的。

    0
  5. frank说道:

    ?你这个配置不就是一个口的配置么,你想问什么呢?

    0

留言哦

blonde teen swallows load.xxx videos